Home        Store        Docs        Blog

T200 in full on arming


(manson) #1

514/5000
After mounting the Blue ROV2, the 2 vertical motors start to run at full speed when the program is armed. The pad has been configured and works perfectly. I manage to reverse the direction of the engines and reduce the speed by pushing the stick fully but the engines only works in one direction. I am in manual mode.
In fact, it seems that the esc are not properly configured. Is there a procedure for configuring ESCs?
The other 4 engines are working properly.

Johann


(Jacob) #2

Hi @interdrones,

Is it a specific thruster that is having the problem, or all of the thrusters?

Does this behavior occur in MANUAL mode? The motors will always spin in the other modes to try to stabilize the vehicle in water (it won’t look right in air). Only MANUAL mode should be used for tests in air.

When did you purchase your ROV?


(manson) #3

as described above the other 4 engines are working properly and I am in manual mode. The ROV was purchased last February.

johann


(Jacob) #4

Are the wires on the ESCs that connect to the thrusters (red,yellow,black) or (blue,green,white)? I am trying to determine which hardware version you have.

Please find in the application title bar menu Widgets->Mavlink Inspector->Vehicle 1.

Expand the fields for RC_CHANNELS_RAW and SERVO_OUTPUT_RAW. Please let me know the values for channels1-6 in these fields before and after arming.


(manson) #5

The wires are blue, green, white.
Forc RC_CHANNELS_RAW :
value for channels 1-6 = 1500 before and after arming
for SERVO_OUTPUT_RAW
value for channels 1,2,3,4, = 1500 and for the 5 = 1100 and the 6 = 1900


(Jacob) #6

Does the mode indicator at the top of the screen in QGC say MANUAL?

Does the artificial horizon/attitude indicator appear correct, or does it look like the ground is sideways?


(manson) #7

Yes the mode is manuel and the artificial horizon/attitude indicator appear correct
Green below and blue in height


(Jacob) #8

Can you please verify this. It’s an unexpected result.


(manson) #9

I confirm


(Jacob) #10

@interdrones I’ve replied to your email. Let’s continue there.


(Jacob) #11

The problem was the RC3_TRIM parameter had been set to 1500 (should be 1100). This can be the result of loading a parameter file from a 3.4 firmware version (more than 1 year old).


(manson) #12

problem solved
thank you Jacob