Home        Store        Docs        Blog

Error when flashing to AfroESC 30A

I’m trying to flash the AfroESC 30A mini ESCs but I’m running into some problems.

The ESC is powered by the main red and black cables, and I have the pwm connector plugged into an AfroESC usb programming tool. I removed the power cable and have only connected the signal and ground to the programming tool.

I’m trying to use avrdude to flash the hex file from: link

The bash command I run is:

sudo avrdude -c stk500v2 -b 9600 -P /dev/ttyUSB1 -p m8 -U flash:w:afro_nfet_besc30_r1.hex:i

This returns the following error code:
Screenshot%20from%202019-06-16%2013-19-08

I got the location with

ls /dev

So I’m quite sure /dev/ttyUSB1

I’m having a difficult time finding someone with the same error code. Any advice?

Hi Morten,

We haven’t had great luck reprogramming the Afro ESC with the Afro Programmer. We’ve had better luck using the ArduinoUSBLinker program on an Arduino Uno. If you have one of those available I would recommend giving that a shot. We have instructions here: http://docs.bluerobotics.com/bluesc/#assigning-i2c-addresses (this is for our discontinued BlueESC product, but the process is the same).

-Rustyx

I’ve tried using the ArduinoUSBLinker with the KKMulticopter flashing software. Doing this I still get a stk500v2: timeout error when trying to flash the hex onto the AfroESC.

Morten, okay. Do you have multiple Afro ESCs or are you just trying with one? We used to program a lot of these at a time and 2-3% of them would just never respond and had to be set aside. If you bought this from us then it has definitely been reprogrammed with the ArduinoUSBLinker before.