Home        Store        Docs        Blog

Downunder ROV build

(Jacob) #61

Glad to hear it. You should try this:

[youtube https://www.youtube.com/watch?v=u4nUgGy-l7c&w=560&h=315]

Instead of althold, set the last flight mode to ACRO.

Edit: Actually, you need direct inputs for roll and pitch to do this. I think roll and pitch are disabled when using qgc input.


(Andrew) #62

I tried before I saw your edit - ended up with some interesting moves - especially the backflip :slight_smile:

(Andrew) #63

With a bit more practice, Acro mode works with the roll trim buttons to get it rolling over, slowly :slight_smile:

Jacob - What depth sensor are you using? I started getting slow bouncing on the alt hold mode running your params, so had to turn down the I & P a bit. This may be because we’re running different sensors - or might just be differences in frame design?

(Jacob) #64

I use MS5803. What amplitude are we talking? Did this occur spontaneously, while stationary? If so, was it continuous, or sporadic?
I don’t think the sensor type will make a huge difference at this point, but I did have the gains up pretty high, so maybe.

(Andrew) #65

Up to about 30cm amplitude, increasing in amplitude over time - spontaneous while stationary - not apparent while moving.

I swapped to the MS5837-30BA a few weeks ago.

(Andrew) #66

Setting POS_Z_P at 1.5 seems to have resolved the bounce

(Andrew) #67

Jacob - I see that the github Ardusub master has been updated overnight, does this now include the commits you referred to above.

The firmware you sent through is working great, so keen to get the source files, apply the few customization I need for my setup and then it’s off to try it out in the real ocean with an exploration of a couple of reefs in the Hauraki Gulf!

Now that a few minor hardware glitches have been sorted, the setup of Laptop (qgc) -Ethernet-> RPi2 (Mavproxy) -Serial->Pixhawk is proving to be very reliable. The biggest issue, now resolved, was that the usb connector on the RPi2 was a little loose, causing intermittent dropout of the RPi2.

(Rusty) #68

@Andrew - Yes, I pulled in the most recent Depth-Control branch. Should be working great but I haven’t tested it in the tank yet.

Feel free to jump into the developer chat on Gitter: https://gitter.im/bluerobotics/ardusub. It’s a bit quicker than forums posts.


(Andrew) #69

Finally the planets aligned and the weather was fine on a non-work day!

Today was the first sea trial and all went fantastically well. No leaks (for the first day out only went to 18m).

Need to build a shade for the laptop though, very hard to see in sunlight.

(Andrew) #70

Screen shot of 17 F310 buttons

(Andrew) #71

Not a good day for the ROV today.

I was exploring at a depth of about 5m when the display suddenly went blank and all comms were lost. I used the tether to retrieve the ROV and the endcap of the main tube was completly missing. :frowning: :frowning:

All electronics have now had a saltwater bath :frowning: Back to build mode again.

My main question though is why this occurred to prevent it happening again? Anyone else experienced this?


(TCIII) #72


Was it the front end cap of the main WTC?

If so, a combination of very warm water in the area that you were diving plus the heating of the air within the WTC by the RPi/Pixhawk and any ESCs within the WTC probably caused an over-pressure condition that pushed the end cap out of the WTC at such a shallow depth.

A way around this issue is to run the ROV on the surface for a while with the Pressure Relief valve open to help vent the warm air in the WTC so that there is not an over pressurization of the WTC at shallow depths in warm water.



(TCIII) #73


Do you remember what the sea water temperature was that day?

Are you on the North or South Coast of NZ?

When I operated in the seas round the Philippines it was not unusual for injection temperatures to hover between 90 - 100 degrees F.

The higher the sea water temperature the greater the reduction in the transfer of excess thermal energy from the Navigation Controller WTC to the surrounding sea water.

I have an OROV WTC with the new upgrade HD Camera and they recommend venting the WTC to the atmosphere with the Controller Board running for 10 - 20 minutes to prevent the thermally caused rise in pressure in the WTC from pushing out the WTC vent plug. Their vent plug is nothing but a cutoff 1ml syringe end with the plunger at the bottom of the syringe.



(Andrew) #74

Thanks @TCIII

Your description is I’m sure exactly what happened.

I’m based in Auckland, New Zealand (the other Downunder :slight_smile: ), so the water is not particularly warm - yesterday it was only 67.1 F. But now, in hindsight, I did make a particularly stupid and costly mistake. I left home to head out at around 5:30 am and it was a particularly cool morning. I screwed in the vent plug when I left home and I’m now almost certain I didn’t reopen the vent plug as I should have, just before the dive. So sealing the WTC at a paticulalry cool temp, then dropping it in much warmer is a recipe for disaster.

An expensive lesson I won’t forget.



(TCIII) #75


Bummer, to say the least.

The new BlueROV2 holds the main WTC in place on the Frame by the use of a couple of right angle clips at each end of the WTC that anchor the End Cap/O ring Assembly to the Frame. Besides anchoring the WTC to the Frame, they will also help keep the End Cap/O ring Assembly from being pushed out from the WTC Tube by any increase in the air pressure within the WTC caused by internal heating.



(Andrew) #76


Just been thinking through the very issue of holding the end cap in place. My short term option used cable ties, but I’ll have a look at the BlueROV2 solution too.

Meantime seeing what I can salvage - have soaked the electronics in a mild “Salt-Away” solution, just waiting for things to dry. It’s a longshot, though worked for one of my mobile phones I dropped overboard.


(TCIII) #77


Hopefully you have taken the right action and some if not all of your electronics can be salvaged!



(Andrew) #78

So far,

Not surprisingly, the power module for the Pixhawk is toast

The tether S board powers up OK and seems to work fine. Camera module looking similar.

Pixhawk is still drying out.

Longer term corrosion may still be an issue.

Went diving for the end cap, but couldn’t be located.

(Andrew) #79


Just tried the Pixhawk and it powered up and calibrated just fine :slight_smile:

5 out of the 6 ESCs are dead though.

Seems that any components with high current flow at the time of flooding are dead. Low current devices are mainly OK for now.


ROV light placement
(TCIII) #80


Nice. The more expensive components made it though.

My vectored six thruster ROV uses BlueESC Thrusters so there are no ESCs in the Navigation Controller WTC.