Home        Store        Learn        Blog

Sonar Installation

Hi Jim,

Seems like the camera isn’t the issue then.

  1. Just realised you haven’t mentioned the results from bypassing the fathom-Xs and the tether with a direct ethernet connection between your raspberry pi and top computer. Would you be able to try that please?
    If it works correctly then you know the problem is isolated to the tether itself, one of the fathom-X boards, or the connections between them, which at least rules out any issues with your top computer and the companion computer. Similarly, if that doesn’t work then you know the issue is either with the RPi companion computer or your top computer, or possibly a software issue.

  2. You can try downloading the latest release of QGC, which is known to fix some video issues, but my expectation is it’s unlikely to solve your issue in this case as QGC in the top computer doesn’t control how the companion computer sends its video streams.

  3. There’s a minor possibility that setting the “power line frequency” in the Camera page of the web interface to 60Hz could help, if you’re living somewhere that uses 60Hz mains power.

  4. It may also be worth checking the network speeds when you’re using lower frame resolutions and rates, although if I remember correctly you said previously that that didn’t help (but that may have been to a different problem).

Eliot
I do not have ethernet on my topside computer, I have access to a friends computer in the morning, I do not know yet if it has a ethernet connection. I will let you know. I removed the jumper tether and I reconnected the Tether, and Fathom X and hooked the the camera back up as it would be in a default Condition, i was not liking have everything taken apart and strewn around… Next thing i would not know how to get things back together, I could undo things if need be though, I did do a speed upload and down load again with everything connected back to normal. the speeds were, upload (41.443) download (9.383) i will see in the morning if another computer will make the difference . and try Downloading latest QGC and see what happens… I will also check web interface and see what it says

I know this is a headache, Especially me not being a computer Wiz, and Windows 10 makes it more difficult for me.accessing in windows 10 is a lot different than previous window programs.

Thanks Eliot

1 Like

Presumably you’re using an FXTI box on the top-side then, which includes a Fathom-X board as well as an ethernet to USB converter (I gave some more detail on this a few comments ago). If you’re ok with turning off your wifi temporarily you likely have an ethernet cable to your router which you could take out test things with, or you may have a spare one somewhere else.

These definitely aren’t normal speeds, and it’s odd the upload seems to have dropped quite a bit since your previous test when it was open.

My main suspicion is something isn’t fully plugged in, or has corroded or otherwise damaged contacts, and the most likely candidates I can think of are the loose wire connections, like the jumper wires between the fathom-X and the tether, or things like the power wires to the raspberry pi.

If the blinking is worse when you use the joystick control to tilt the camera then it’s more like a power or signal noise issue. Same applies for if you run your thrusters (although if you’re trying that in air then make sure not to push them too hard or it can wear down their bearings).

Appreciate your patience so far, and sorry that this issue has been so challenging and time consuming to hunt down.
Hopefully we can get this sorted out soon :slight_smile:

Eliot

  1. I tried different camera frame rates, tried the 15 frame rate, checked the upload and down load, upload 27ish
    download 11ish, went back to 30 frames rate, upload 56 ish download 13 ish . checked power line frequency both, 50 and 60 hz worked the same, same blinking.
    I am going for my friends computer and try that later this morning, i will let you know. I am also going to go through all the wiring today and disconnect and reconnect while watching the screen at the same time

  2. Tried my friends computer, could not get it to connect, looked at the Device manager and usb ports all okay, Downloaded a second Qgroundcontrol with no results disconnected it. went back to jumper wire from Fathom X to ROV, same blinking, checked upload and down load, upload 47 ish Download 10 ish

No ethernet on my friends computer either.

  1. I also went through the wiring again wiggled and moved around but no change to the Blinking
    also i have the fathom X box.

  2. Connected controller to computer ran the camera up and down several times no noticable difference.
    I do not have a Ethernet to Usb adapter, i could probably fine one.

  3. Disconneted my jumper wire from ROV and fathom X, Connected my FathomX to 8 Conductor Tether to the ROV Than to the Fathom X Board, speed results (Upload 38.300 Download 10.54) Same Blinking

  4. Disconnected my Fathom X 8 conductor tether, Reconnected my Slim Tether through the Fathom X Box Upload speed 53.404 Download Speed 6.317

  5. Checked upload and Download speed 10 Minutes later same tether connection upload 28.482 Download 10.459 will try again in 10 minutes

  6. 10minutes later upload 29.558 Download 8.159

  7. 12 Hours later     upload 43.529   download  17.50

Connected directly from the rasberry pi to the topside computer through a ethernet USB adapter with no results at all, i could not get the ArduSub network page either. Tried 2 different ethernet cables also.

Connected the ethernet cable into ethernet port on the rasberry pi connected directly to the ethernet port inside the FXTI box than connected it to the computer as i would if everything was normal, Same Blinking on the Display, Changed back to jumper wire to bypass tether , same results. Its definetly not in the Tether, Ive tried the 8 condutor tether , slim teher, jumper wire, Same results
Checked the Network speed again, upload 30, download 8,

What is the proper speed i should be looking for???

Did you have any luck with this?

By “jumper wire from Fathom-X to ROV” are you bypassing the tether with a shorter pair of wires, or am I misunderstanding?

You should have over 50mbps both ways. I have quite a short length of tether for testing with and get 85-90mbps both ways, but longer tethers will tend to be a bit lower. 30 and 8 are significantly lower than expected unless you’re running several additional services/network programs beyond what the ROV normally does.

Can you confirm that this is the setup that you were trying:

NOTE:
It’s possible to bypass the USB A to B converter and USB B to A cable and instead just plug the USB A output from the Eth to USB converter directly into your computer. I included them because the FXTI box includes the USB A to B converter, and that’s how it’s normally used.

That should definitely be able to connect - the Fathom-Xs boost the signal so it can go further, but replacing the whole “Fathom-X → tether → Fathom-X” setup with a shorter direct ethernet cable should basically always be more reliable and at least a bit faster.

As a separate note, someone recently had some network issues with companion 0.0.26, so it might be worth trying to go back to 0.0.25, in case that helps.

When i say jumper tether, i mean my 5 ft one, it off of my new slim tether, i also tried as i said in previous post, i tried my 8 conductor tether, and my slim tether, also bypassed the fathom spool and always the same results. I have both the fathom Xs boxes connected with the Blue and white short jumper wire to the sensor plugs like in your diagram. and i understand the first diagram the ethernet cable coming out of the fathom X going to the ethernet to usb adapter, but i do not understand the USB Am and the USB BF part. I see only one usb port in the fathom X, do i disconnect what is connected to it and plug in the ethernet to usb plug into it. i hope i am clear enough, Its the AM and BF that has me confused .

Thanks eliot

Sorry, the M and F shouldn’t be there (or at least should both be Fs). That little box is a USB type A (flat rectangle plug) to USB type B (square with two cut angled corners plug) converter. That’s something that comes as part of the FXTI box, which I believe you said you’re using

The idea with my diagram was that the top is a normal setup, and I’m suggesting you try the bottom which doesn’t connect to either fathom-X and just directly uses an ethernet cable from the raspberry pi to the top computer (via an ethernet to USB converter in this case).

The USB A to B converter isn’t required (since you then plug a USB B to A cable into it) - I just showed it on the diagram because it’s less to unplug/rewire if you leave it connected.

The simplest setup in terms of fewest components is
RPi → ethernet cable → Eth to USB converter → top computer

The setup I drew (bottom half) is
RPi → ethernet cable → Eth to USB converter → USB A to B converter → USB B to A cable → top computer

EDIT: I updated my previous comment to avoid the M/F on the USB A-USB B converter and specify what the top and bottom represent in the image, with an additional note on going straight from Eth to USB converter to computer.

Thanks for setting me straight on The A and B, i suspected that was the way it went, I tried both diagrams again, Ethernet cable from Rasberry to Ethernet Converter to USB as in your second diagram.
Blue and White Tether to sensor ports on Onboard Fathom X to Topside Fathom X. just as in the Diagram. Tried 2 times, It would not connect, Tried the first Diagram same thing, it would not connect. If i connect it back to the Default wiring, it connects, But Blinks , when i say default, i mean the way it is wired from the factory.

The fathom-X and tether connections aren’t relevant as the whole idea here is to disconnect from and bypass them - the ethernet cable is supposed to act as a bypass/replacement for fathom-X + tether + fathom-X setup (or more correctly, the fathom-X + tether + fathom-X setup is supposed to be roughly equivalent to an ethernet cable, just with extended range).

Is there a difference between this and what’s shown in the top half of my diagram? I believe they should be the same (my diagram’s “normal setup” should be what you got “from the factory”).

There are 2 ethernet ports in the Fathom X Box , they are connected with a 4 inch J45 plug on each end.,in order to connect to the ethernet to usb converter you have to disconnect one to connect to the ethernet to usb converter.If i do not disconnect one or the other, its what i would call normal, it connects but blinks . On your top diagram Fathom X FXTI shows ethernet cable dropping down to the Ethernet to usb converter… I do not know which ethernet port to use, to connect to the ethernet to usb converter., i assume it is the one on the same side as the blue and white tether connection as in the Diagram, if i disconnect one and connect to the Converter and to the A port than to the computer it does not connect

Would you be able to send some photos of the connections you’re using? I think we’re talking about the same thing but would be good to make sure. If your ethernet connections are correct then I can’t understand why it wouldn’t connect unless both the ethernet cables you tested with don’t work unless both ethernet cables you tried are broken, which seems unlikely.

They are not broken, I am using one of them right now to use my wifi, There are 2 ether net ports inside the Fathom X board with a 4 inch wire with j45 plugs connecting them together , in order to connect to the Converter you have to disconnect one of them so that you can connect to the ethernet to usb converter. when you do that it does not connect. to the computer.Tell me which Port to use and on which side of Board.


This setup works as expected, and is a bit faster than via the fathom-Xs and tether. Apologies for the difficult to read red text - it’s just outlining that the short ethernet cables to the fathom-Xs are unplugged from the RPi and the Eth to USB converter, and replaced with the bypassing ethernet cable.

On the USB to Eth converter I’ve got three lights - red (right side), green (middle), and yellow (left). The yellow light flashes when the ethernet cable is plugged in and communicating to the ROV’s RPi.

When i wire it up like that, it does not communicate with the computer. what i meant by default, is you reconnect the Red Circled items in the photo rasberry pi back to the Fathom X in the ROV, Than Reconnect the short ethernet cable inside the topside fathom X and than it will communicate with the computer, but it blinks. But it does not communicate when connected like in the photo, I swapped ethernet cables again, also. The ethernet to usb converter is new, i paid 35.00 a few days ago. It is a Manhattan. You mentioned that you had 3 lights on you converter, mine has no lights.

Are you using the one from inside the FXTI box, or a different one?

I am using the same set up as in your photo, Inside the FXTI .There is a Red llight and 2 green lights on it, no yellow light I did not even know it was a USB to ethernet converter. I have a seperate coverter.

To check that I’m understanding you correctly, do you now have:

  1. ethernet cable connected from RPi to the FXTI box ethernet to USB A converter
    FXTI box ethernet to USB A converter connected to USB A to B converter (default)
    USB B to A cable between the USB A to B converter and your computer’s USB A port

  2. ethernet cable connected from RPi to FXTI box ethernet to USB A converter
    FXTI box ethernet to USB A converter connected directly to your computer’s USB A port

  3. ethernet cable connected from RPi to your new ethernet to USB A converter
    your ethernet to USB A converter connected directly to your computer’s USB A port

  4. something else?

I have it wired exactly as in the photo. I was editing while you were posting. I did not know that was a USB to ethernet converter inside the FXTI . I have 2 Green lights and 1 Red light, no yellow. light, i have no other connections other than what is in the Photo.

Ok, is it working?