Home        Store        Learn        Blog

Sonar Installation

Hello
Trying in Vane to Get my ping 360 Going with no luck, I have gone through the wiring process several times, but no success, It is not connecting to the Ping Viewer. I have tried turning my Firewall off, Checked the Device Manager. but nothing. A extra wire came with the Ping 360, but i did not see it in the installation tutorial . I have included a photo of it.

any clues as to where this goes

Thanks in Advance

Hi Jim,

Are you able to use QGroundControl with your ROV? If so it’s unlikely to be a firewall issue. Maybe try connecting to the Ping360 via the companion computer? Companion is set up to connect to it by default and provide a connection point for it through the tether, and PingViewer can then connect to that.

Also make sure you’re powering it appropriately. It needs 11-25V, as per the technical details section.

If you’ve tried/checked both of those and still not had success I’d suggest you email support@bluerobotics.com and link them to this thread, and they can help make sure you’ve checked everything relevant, and sort out a replacement if you’ve received a faulty product :slight_smile:

The ‘Wiring’ subsection within the Contents section specifies that the Ping360 comes with the following:

In the wire in your image the small white connector is the “4-pin JST-GH” connector, and the black connector with two pins sticking out is the “male header pin adapter”. It’s used if you’re changing the Ping360 to communicate over RS-485 instead of via USB, so assuming that’s not what you’re doing then it’s fine for that cable to not be in use :slight_smile:

Thanks Eliot

I am not a computer wiz, i can make them work, but i am not 100% sure what is meant by companion computer. Is it the what i would call the topside computer?? Also i noticed today after i got the wiring all connected and was trying to connect Ping Veiwer that my Video was Blinking off and On, In the past when i lit QgroundControl, off it woudl blink a couple of times than quit and normalize. But since i wired it up , the video would blink continusly.

Maybe in the morning i will start again and Disconnect all the Ping 360 wiring and See what happens with QgroundControl whether it Does the Blinking Thing again.

Thanks Eliot

Ahh sorry, the companion computer is the Raspberry Pi (inside the ROV). I was assuming you were starting out trying to get the Ping360 working while directly plugged in to your topside computer, and was suggesting you might want to try connecting it through the Raspberry Pi instead.

If you have already been connecting through the companion computer I’d recommend restarting it once the Ping360 is plugged in (using either the ‘Reboot’ button at the top right of the web interface, or unplugging and re-plugging in the battery), or just plugging in the Ping360 while the ROV is off, and then connecting the battery/power. When the Ping360 is detected you should see it come up in the Active Services as Ping360-id-..., at which point PingViewer should be able to find it as well.

It also might be worth trying to connect directly to your top computer if you haven’t tried that already (note that the companion web interface won’t exist in that case, so you’ll just have to see if PingViewer detects it, and possibly check your Device Manager). If you’re trying this and it’s not showing up then have you tried installing the FTDI driver mentioned in the last FAQ & troubleshooting point from the PingViewer documentation?

That shouldn’t be happening, but there are a few different possible causes:

  • insufficient power from your battery/power supply

if connected through companion computer:

  • tether/communications issues (try checking your network speed - both upload and download should be ~80Mbps)
  • companion computer overheating (try testing with the ROV in water, or with the electronics open to the air (e.g. out on a bench) instead of in the enclosure)
  • old version of companion computer (try updating through the web interface - there should be a companion software update section in the System page, click Stable if there’s an option for it)

or if Ping360 is connected directly to your topside computer, while the ROV is also connected through the tether

  • too much network usage for your computer (check the Network column in your Task Manager - it’s unlikely this is the issue)

Eliot

I Tried Direct connection from the USB cable inside the BR to my Laptop, but was the same no connection to Ping Viewer . I also reconnected all the Wires as in the Installation Tutorial, but nothing
Rebooted everything, Checked the Device Manager, it shows nothing. Video is still blinking.Blinks only when connected to Qgroundcontrol, Does not do it when connected online.,Voltage is over 16 volts.





but the same

Shouldnt the Sonar make a noise of some sort or vibration?? It seems just Dead.

First photo is The Wiring installation by the Tutorial
Second photo is the Direct Connection from Ping 360 via the USB cable in the BR with ping viewer in Background
and a photo of the Device Manager.
All the hardware, Camera tilt, lights, Thrusters, they all work , Just the blinking screen and Sonar that does not work.
Did a direct connect from ROV via Sonar short USB cable to Topside computer and watched the Device Manager USB Controllers No activity
Double checked the Power leads again,
I have not swapped the TX and RX leads yet, ( I assume they are The Ethernet Tether Wires)
The electronics should not be over heating, i have the System out of the tube in open air. at home.

Updated the software in Rasberry pI, Sonar works fine now. Still have Blinking screen though, Only blinks when connected to Qgroundcontrol. nowhere else.

1 Like

Glad to hear you got this sorted :slight_smile:

Did you try doing the network speed test? What were the results?

I do not know how to get the Network speed Eliot, The Blinking started when i hooked up the Sonar and continues ever since, I totaly disconnected the sonar wiring from the ROV still keeps blinking, I tried everything from the forums i could find. changed resolution, a bunch of times still the same, Does not blink when use it online works fine, just when i am connected to the ROV. I thought when i updated the software in the Rasberry pi it would cure it, but it did not. It cured the connection problem with the Sonar Though. Everything has been ok till i connected the Sonar. I am not 100% sure the sonar works , it does connect and seens to work ok in open air, I cant try it out till i get the blinking stopped. Drives me nuts

I will google Network Speed and find out how to do that.
I will let you know

Thanks Eliot

The companion web interface has a Network page that shows up when you’re connected to the ROV. I’ve linked you to the description of/information about that page, but on the page I’ve linked to there’s a ‘Network’ link near the top which will take you to the actual web interface page, assuming you’re connected to your ROV.

At the bottom of that page is a section called ‘Test Network’, with buttons to test the upload and download speed between the ROV and the topside computer :slight_smile:

Thanks Eliot
I will try that and let you know

1 Like

I got the network speed, i do not know if its right, but Wifi speed is 130Mbps ethernet is 100 Mbps transmit and receive

The idea is to check the communication speed between your computer and the ROV, not your general internet speed. The companion web interface is hosted locally by the companion computer in the ROV, and it’s been set up so it can be used to directly measure that desired communication speed.

The upload and download speed generally don’t get much higher than 90 Mbps because the Raspberry Pi 3B only supports up to 100. With a standard configuration it’s at least an indication that something might be wrong with the connections/tether (e.g. corrosion, bad wiring, loose wire, etc) if you’re getting ~50Mbps or lower.

Eliot
I Jumper wired FathomX direct to the Rasberry PI with a 5ft piece of thin tether that i had and bypassed the Tether and the spool, So that is not it, I found the upload speed is 55.090mbps Download is 6.720 mbps. I totaly disconnected the Sonar. I do no think it had anything to do with the Blinking screen just a coincidence. jiggled the wires while watching the Screen to see of any indication but there was no indication at all. i also shield the the wires with tin foil but nothin, kept on Blinking. I am going to hopefully find a friend with a Laptop to use and connect it to Qgroundcontrol although I got the laptop i have brand new last winter when i purchased the ROV. And like i say it does not blink when i do other functions, I do know i have a Desktop Acer windows 7 computer on my boat for navigation, I programed my Radar to overlay on the navigation charts that i use, I had to put a Gamer Video Card to make it Work. It works on ethernet also just like the ROV.
My computer is a lonovo windows 10 it has a Radeon Graphics all my equipment is fairly new bought it last winter and even replaced the the 8 conductor tether with 2 conducter just a month ago, I have only dove the equipment maybe a dozen times Flushed after each dive in fresh water. I read on one of the Posts on the forum about another fella had problems with a Radeon . Maybe i am barking up the wrong tree, but i have to do something, its worthless to me the way it is. I tried downloading Qgroundcontrol onto my home computer and trying that route, but i have windows 7 and it would not work.

Thanks Eliot

The upload isn’t amazing but is likely fine to operate on. That download speed however is abysmal, no big surprise that your video is blinking. Can you try plugging an ethernet cable directly between the companion computer and your top computer (no fathom-Xs in between)? Given communication in one direction seems ok-ish it seems unlikely to be the cable, so my suspicion is one of the network electronics is damaged - either your computer’s or the Raspberry Pi’s network card, or one of the fathom-Xs.

From memory that’s to do with a video decoding issue of software vs hardware, but I would expect that’s not what’s causing your download speed issues. If you want to test a couple of things in this direction, try unplugging the camera USB cable and re-testing the network speed. If that helps then you might want to try the QGC download in this comment, or possibly try using QGC 4.1 (noting that it may not work correctly with all aspects of ArduSub, as I mentioned to you here).

How would i connect bypassing the Fathom X? . would i connect to the Rasberry pi by way of any of the usb ports on the RasberryPI or a particular one, than to the Computer??

The fathom-X setup works as an Ethernet extender. To bypass it you plug an Ethernet cable into the raspberry pi’s Ethernet port, and the other end into your computer’s Ethernet port (assuming you have one).

If you don’t have an Ethernet port on your computer, and are using an FXTI box instead of a plain fathom-X board for the top side then if you want you can take the box apart and plug your Ethernet cable into the little Ethernet-to-USB adaptor in there, and plug the USB jack from the other side of it into your computer like you normally would with the FXTI.

Eliot
I Disconnected the Camera, Download speed is 55…339, Upload is 65.52, I did it twice just to be sure connected and disconnected . Upload speed when connected was 55 ish Download is 11 ish

Very interesting.

  1. Are you using the BlueRobotics Low Light camera, or something else?

It definitely shouldn’t be taking up 55Mbps of bandwidth to send the normal camera stream - it should be more like <10.

  1. I’m wondering if possibly you just have a faulty camera, can you try plugging the camera directly into your computer and seeing if it’s got a stable stream that way?

It’s also possible you’ve got an insufficient power supply capacity.

  1. How are you powering your electronics when doing these experiments?
  2. If you’re using the BlueROV battery is it well-charged?
  3. If you’re using something external like a bench-top power supply what voltage are you supplying, and is it hitting a current limit?
  4. Have you made other additions to the ROV, outside of the ping360?

Its the same camera that came withe the ROV From Blue Robotics, Power is fine, I hooked the camera direct to my computer, but where do i find if the camera is streaming, i am not that familiar with window 10 ,

Found the Camera, it works fine connected drectly to the Laptop, no blinking, reConnected it to a different USB port on the Rasberrypi, started blinking again. Looks like someting in the Rasberry pi.

I found it, Camera is not blinking, Now what???