Home        Store        Learn        Blog

Software Updates

If you purchased your BlueROV2 after June 2017, you do not need to do this software update!

We’ve got a big round of updates! To start, ArduSub V3.5 has been released and is the now the current stable version of ArduSub. You can see the release notes for ArduSub here.

QGroundControl has seen many updates since 3.1.3 (no more calibrating joysticks in reverse!), and we are now recommending an updated build for use with ArduSub (required for use with ArduSub v3.5 and up). This version of QGC has many bug fixes as well as some great new features; notably: the ability to record the live video stream directly to your computer’s storage, and joystick hotplugging support.

We have also added a web interface to the Raspberry Pi companion computer on the BlueROV2. This web interface will allow you to apply future updates for both the companion computer and the Pixhawk firmware with no need to access the electronics inside the enclosure. The new companion computer image also has these features:

  • allows the use of USB webcams for video streaming (keep an eye on our store!)
  • provides a user interface to make it easy to add new sensors and payloads, and configure where the payload communication should be routed
  • fixes a broken GCS communication failsafe mechanism for ROVs sold before January, 2017
  • provides a means to quickly adjust and test the Raspberry Pi camera and video stream settings.

Instructions for updating each software component are below. The components should be updated in the order that they are listed.


Download and install an updated version of QGroundControl from the appropriate link below:


Raspberry Pi/Companion

  1. Remove the SD card from the Raspberry Pi in your BlueROV2 and plug it into your computer with a card reader.
    • Remove the two bolts that hold the retaining clips against the electronics enclosure cradle. You will then be able to slide the enclosure tube towards the front of the ROV to remove it and access the electronics.
    • Remove the two bolts that hold the circular camera mount assembly to the long bule aluminum standoffs.
    • Move the camera assembly aside, and you will be able to access the Raspberry Pi SD card. Pull the SD card straight out of the Pi to remove it (it does not have a spring to eject).
  2. Download the Raspberry Pi image here
  3. While the Raspberry Pi image downloads, download and install Etcher. Make sure you select the correct download for your Operating System!
  4. Open Etcher, select the Raspberry Pi image file (no need to extract beforehand) and your SD card, click ‘Flash’ and wait for it to complete.
  5. Eject the SD card, and place it back into the Raspberry Pi.


  1. Turn on your BlueROV2, and connect it to your computer

  2. Open a browser, navigate to

  3. Enter your WiFi credentials to give the Raspberry Pi internet access, then click the ‘Submit’ button, and wait for the Raspberry Pi to connect to your network.

  4. When the web page indicates that the Raspberry Pi is connected to the Internet like the picture above, click the ‘System’ link at the top of the page

  5. Click the ‘Stable’ button under the ‘Update Pixhawk’ section. You may see this message appear many times for several seconds, that’s ok, just let it run…
    if the board does not respond, unplug and re-plug the USB connector. attempting reboot on /dev/ttyACM0...

  6. Wait for the update to complete, and you are done, you’re running ArduSub 3.5!

Note The GND_EXT_BUS parameter needs to be set to 1 for the depth sensor to function. Verify the value from the Parameters tab in the Vehicle Setup page. If it is not set to 1, you can change it by checking the ‘Advanced’ and ‘Manual Entry’ boxes in the parameter editor.

That’s all for now, please post your success stories or troubles involving the update process here.


Software update was a simple process
But have lost temp 2 (scaled pressure 2) and when recalibrating the depth sensor, it comes back with “bad depth” ," pressure calibration failed" then "calibration command failed. Finally QGC falls over.
The depth was way out a couple of days ago. Started at 300 and steadily dropped over a half hour down to -100. It took 3 calibrations to zero out but even then it rose to +14.5 over half hour.
I have physically checked all the wiring and pushed on the baro to see if it would give pressure difference but no change.

Am i missing something obvious??

Ok @kaosrulz, set the parameter GND_EXT_BUS to 1 (this tells the autopilot to look for a Baro on the external I2C bus). It should have been set to 1 by default, but I’ve heard from a few people that it they need to change this parameter after the upgrade. I will make a note of this in the instructions.

1 Like

@kaosrulz Is QGC crashing consistently/regularly?

It was crashing consistently while external baro not activated in parameters but now is stable and fully functioning on bench. Will splash tmora weather permitting

Just updated my ROV. Clicking on the “Stable” for me installed 3.4 and “Beta” installed 3.5. No other issues for me though and I didn’t have the barometer fault.

Jacob, this is an outstanding update and makes it a heck of a lot easier to update things. The software is looking really good now and I appreciate all your hard work into making this easier to set-up.

Here’s what I think happened (I’ve just tested this):

QGC was open, ROV connected, and ArduSub 3.4 running.
ArduSub update to 3.5 was applied according to the instructions.
QGC was not aware of the new version running and still showed that 3.4 was running.

ArduSub 3.5 is properly loaded; QGC needs to be re-opened to reflect the update.


Thanks guys, the updates look great, and will install next time i need to open up the WTC. Just wondering, is the recording function a screen recorder, or recording the Pi video stream directly?


Did the update and everything seems to be working on dry land. Still not able to record video ? Message showing says I have to go to settings to fix this.
Has anybody got this recording button working? Is it just me not being a good friend with my computer again ?

I downloaded and updated the QGC software ( downloaded and installed)

Downloaded and flashed the picture into RPi

Looks the same to me as it was before

The raw video stream is recorded, none of the QGC UI is visible in the recorded video.


1 Like

Here are some instructions on how to get recording set up in QGC. There isn’t much difference in the update visually, there are a few more options available in QGC. The web interface on the Raspberry Pi is completely new, you can see that by going to in your Internet browser.


I can not get the latest QGC to work. It does not start. I tried a few times having the same result. I´m using the OSX-version. When I try to start QGC I get an error message saying ‘QGC cannot be opened due to a problem’.

What is the current version the download-link leads to? My previous version (working ok) was 3.1.3. If I re-install 3.1.3 everything is fine again, but I am of course missing some new features. When I check the ‘Get Info’ for the file not working it says ‘Version: 3.1.2’. Is that correct?

I have tried downloading the file a few times, both from the above link and the link found at qgroundcontrol.com. I will try to add some screen shots in a separate reply.

Any ideas?

Hi Niclas, it appears the new Mac version is broken. I’m working on a fix, I’m taking down the link for now.

Thanks Jacob! Looking forward to the new version. :slight_smile:

I like the web interface and will make the update process much easier.

It took a couple of days but testing gets 5 out of 5. Great new features n browser interface is clean. So much potential wrapped up in open source. Well done for all for yr hard work, team

Just tried the new Mac-version. It works great! Amazing work guys! Thanks!

I am able to access the web browser and connect to Wifi but I still have Internet Status: Not connected. I do have internet access through my Wifi. Any ideas?

Hi Ryan!

This is a first.

Can you please enter your wifi credentials again, and click the Submit button. Then wait for about 15-20 seconds (it may take this long to connect). If it does not connect, please go to where you will see a file called ‘.webui.log’. You can click that file to download it, then please upload it so I can review it.

Best, Jacob