Setting Deadband

Is there a simple way to set up the deadband when using the Xbox controller? I’ve clicked the Deadband tick box in the advanced settings but the controller is still way to sensitive and its virtually impossible to stop the thrusters turning. I’ve searched for this in both BlueR site and Ardusub but cant find anything simple. Theres a few coding options mentioned but I’m not a programmer and prefer not to start messing with the code.
Or should I just change to the Logitech controller which others have suggested has a much better deadband?
Thanks. Nemorov.

Hi, just so you know, the thrusters will always spin in every mode other than MANUAL, because the autopilot is controlling the motor outputs in order to stabilize the vehicle.

If this is not your problem you can try the RC#_DEADBAND parameters from the parameter editor. Here is the mapping:

RC3: Throttle
RC4: Yaw
RC5: Forward
RC6: Lateral