Home        Store        Docs        Blog

Not talking to the sub


(Julian Hancock) #1

Hi

I went out today with the idea of undertaking some more wet testing of my sub. However I have been unable to talk to my sub all day. This after yesterday’s recalibration of the joystick which was fine. I have found the network connection to the sub hit and miss depending of if OSX asks me if I would like to allow the connection?

I have changed a USB network adapter, a thunderbolt network adapter, numerous different network cables and running QCC on my Windows 7 partition.

I thought perhaps it was a hard ware issue but OSX some times asks me if I would like to allow the LAN connection. When I allow it I connect to the sub. I have tried turning the firewall off and/or allowing the QGC to work through the firewall.

Now I am home I have set the system up again and still no connection.

OSX has just asked me if I would like to allow the connection and voila I am connected the first time today?

Any ideas please (scratches head)?

Julian


(Rusty) #2

Hi Julian,

I’m not sure why OSX keeps asking you if you want to connect. Have you gone through the network configuration to set your computer’s IP address to 192.168.2.1? If not, the instructions for doing that are here.

What type of network adapter are you using?

I’m sure we can get this resolved quickly.

-Rusty


(Julian Hancock) #3

Hi Rusty

I have done every thing your instructions tell me to do wrt setup.

I have been experimenting today using both network adapters I have, USB and thunderbolt, the problem seems to be intermittent. If OSX asks me if I want to QGC.app to accept incoming network connections and I say yes then I get to connected to the sub. However about 70% of the time OSX does not ask the question and I do not get to ‘see’ the sub.

I have turned off the firewall and that does not seem to change anything. In fact when I reboot the computer the firewall is turned back on? I have fire wall exceptions that include QGC.app.

Regards

Julian


(Rusty) #4

Hi Julian,

Are you running QGroundControl.app from your /Applications folder or from a installation disk image? It’s a little strange that OSX is asking you that question every time. I think I was only asked that the first time I ran it.

Seems like it could be some sort of security setting in the OS, but I’m not familiar with what that might be.

-Rusty


(Julian Hancock) #5

Rusty

I certainly am running the program from the /Application folder. The only thing I can think of is the firewall however I have the QGroundControl.app running as an exception through the firewall even turning the firewall off seems to have no effect?

Regards

Julian


(Rusty) #6

Hi Julian,

Okay, thanks for the info. I’m at a loss as to what might be causing this at the moment. I’d like to get some more info to see if anything might be odd. I’m interested to know what version of OSX you’re using, what exact Ethernet adapters you have tried, etc.

Also, we should consider the fact that something could be wrong with the Fathom-X interface boards or other ROV side components. Have you double checked those connections?

-Rusty


(Julian Hancock) #7

Rusty

I have tried the Apple (made) USB and the thunderbolt ethernet connectors on a 2011 MacBook air using OSX Sierra 10.12.4.

I have checked all the connections and they are good to go.

Regards

Julian


(Jacob) #8

Can you try connecting a regular Ethernet patch cable between the Raspberry Pi and the laptop? If it works with a patch cable, it’s definitely a hardware issue. If it doesn’t, it could be an issue with software, or the thunderbolt adapter, or with the patch cable.

You can turn off wifi, and plug your laptop into your router with the patch cable. If you have internet access when plugged into the router, then the patch cable and the thunderbolt adapter are good.

These sort of tests will narrow things down a lot. Please let us know the details of what you try, and what the results are.

-Jacob


(Julian Hancock) #9

Hi Jacob

So I understand, plug the laptop directly into the Raspberry Pi on board the sub. I will do that when I get home I am at sea at the moment.

The strange thing is I have tested numerous patch cables, both USB and thunderbolt ethernet connections and Windows 7 from my partition.

When OSX asks me the above question then the connection is rock solid. I have removed a program from my startup that connected me to a proxy server I noticed when this was booted I could not connect to my sub, now I removed it I am asked the question about QGroundControl.app and allowing access?

Thanks

Julian


(Jacob) #10

Precisely.

What was the behavior in Windows?

I’m not sure I understand what’s going on here. It sounds like you couldn’t connect to the ROV before or after removing the startup proxy program.


(Julian Hancock) #11

Jacob

I could not connect in Windows 7, but I have always had trouble networking through Windows 7, frustratingly my version does not recognise the thunderbolt port on my MacBook Air.

I am not sure about the proxy program, it might be a red herring I will have to see when I get home.

Regards

Julian


(Julian Hancock) #12

Hi Jacob and Rusty

I am back from my travels.

I have removed the proxy software, now every time I open QGC I am asked the above connection question. This is a step forward as I was only getting asked that question occasionally so I could only occasionally connect to QGC.

I switch my wifi off and I have connected my OSX lap to my internet router via thunderbolt/ethernet connector using three different cables and I was unable to access the internet but I could speak to my router?

I then used my USB/ethernet connector with the same LAN cables and every thing worked and I was able to access the internet?

Regards

Julian