Home        Store        Docs        Blog

Missing information in QGC instrument panel

#1

Hi there!

I tested the updates on my Sibiu Nano - everything looks fine, at least in my very dry basement. But: In QGS, the new (much uglier then before) instrument panel has lost a lot of useful information: tether turns, pilot gain, camera tilt, all missing… That’s a bit, well… How to get that instrument panel back to old glory?

Thanks, Jochen

Software updates 15 April 2019
(Willian Galvani) #2

Hello,

You can get all the information back, click the gear and it will list you all the data available to show there. Check everything you want.
Screenshot%20from%202019-05-15%2009-21-18

#3

Yeah, I did that - I found depth, voltage and two temperatures (presumably internal and water temp), but I couldn’t find the rest…

Thanks none the less!

1 Like
(Willian Galvani) #4

Try it connected to the ROV.
QGC has to load the sub-specific plugin, then you will see this:
Screenshot%20from%202019-05-15%2009-30-17

1 Like
#5

Thanks, I’ll try again tonight - yesterday, even when connected to the ROV, it didn’t show the “APMSubInfo” bit in your picture. Is this somewhere hidden below other data? Or is my QGS not loading this specific plugin?

(Willian Galvani) #6

It should be there when the Sub is detected. Please report back if it is not.
Please also check that it shows ArduSub(instead of ArduPilot) on the top right of QGC after the vehicle is connected.

#7

Ist shows “ArduSub” quite right - will look for the rest tonight and report back ASAP. Thanks!

1 Like
#8

Okay, I just tested the whole shebang:

Had to do a QGS re-install (# 327…) first due to windows telling me about a “missing link” and strangely: It now works as it should.

No idea if I’ve been blind or QGS didn’t install properly - nevertheless many thanks for your much appreciated help!

Cheers, Jochen

1 Like
(Willian Galvani) #9

No problem, I’m glad you got everything working!

1 Like
(Svein H.) #10

I have also updated to the latest version and think this version is a step back from earlier versions.
First of all i miss the record button on the screen and i also miss the audio feedback from the system.
@jwalser Can i go back to a older version and still be able to run the ping sonar?
That was the reason why i updated the companion and QGC.

1 Like
#11

I also find it frustrating to have to dig out the video record button. I much prefer having it out where I can see it and quickly touch it to restart a new video file without having to go through the menu.