Home        Store        Docs        Blog

Can’t see streaming video in QGC (compiled by myself)


(chuck) #1

I’m trying to compile QGC, but it goes wrong.
I can’t see streaming video in QGC. It shows black screen.
I set up Video Source: UDP Video Stream and UDP Port:5600.

I already installed GStreamer and
I could see streaming video from RPI, using gst-launch-1.0.

Console in application settings shows “…¥VideoReceiver.cc.160 - “VideoReceiver::start() failed because video sink is not set”, I think this is a problem.

Application output in Qt shows “(QGroundControl.exe:8304): GStreamer-Warning : Failed to load plugin…”, I also think this is a problem.

I need to install additionnal plugins to GStreamer?

What should I do?
Anybody help me?


(Patrick José Pereira) #2

Hi Chuck,

I’ll point some necessary things to build QGC successfully under windows.

Right now we have our own fork of qgroundcontrol with some features for ardusub, you can get it here.

  1. To get the source code, you’ll need git to download it with all submodules.
    1.1 Our last release has v3.2.4-BlueRobotics-Rev6 tag.

  2. It’ll be necessary to have Visual Studio 2015, if you are familiar with choco cli, can install it using choco install VisualStudio2015Community
    2.1 You will need to install the c++ windows toolkit. Visual Studio → File → New → Project → Installed → Visual C++ → Install Visual C++ 2015 tools

  3. Install the gstreamer version 1.12. (gstreamer-1.0-devel-x86-1.12.4.msi, gstreamer-1.0-x86-1.12.4.msi)
    3.1 Make sure to select the complete installation instead of typical installation during the final “install” process. The installer places the libraries under C:\gstreamer, which is where the QGC build system will look for it.

After installing this two .msi files, check if C:/gstreamer/1.0/x86/include/gstreamer-1.0 exist.

  1. And finally download Qt here, right now we are using Qt 5.8 with the 32 bits version.

Now, it’ll be only necessary to open Qt studio and select the MSVC2015 32bit version to update the compiler and debug options.

If you are still having problems, please, says which QGC, Qt and GStreamer version are you using.


(chuck) #3

Thank you., Patrick
I will try.


(Bluerobo) #4

Hi,
Is 5.8 OK ?
image


(Patrick José Pereira) #5

5.8 and 5.7 are ok.


(chuck) #6

I still cannot see video streaming.I can see Red “ARDUSUB” instead of that now.

Console shows “at kernel¥qopenglcontext.cpp:825 - “versionFunction: Not supported on OpenGL ES” “ endlessly.

I’m using Qt 5.8 , QGC3.2.4 rev6 , MSVC 2015 32bit and GStreamer 1.12.4(normal ver and develop ver).


(Patrick José Pereira) #7

Hi Chuck.

Qt 5.11.1 by default uses OpenGL ES, others versions of Qt (AFIK) uses OpenGL Desktop. Are you sure that you are using Qt 5.8 to compile QGC ?
Can you share the output of qmake and the compilation via pastebin.com ?
Check if C:/gstreamer/1.0/x86/include/gstreamer-1.0, as I described in my last post. Also do a clean compilation after installing gstreamer. (Empty/Delete the build folder and start it over again)


(Jacob) #8

QGC installs 3 shortcuts on windows QGC, QGC (GPU Safe mode) and QGC (GPU Compatibility mode). Try one of the other shortcuts. I don’t know if the shortcuts can be found when building from source (probably not). The difference is in the arguments to the program, they are here.

Why are you trying to compile QGC? I suggest you switch to linux for development.
.


(chuck) #9

Hi. I’m sorry for not replying for a long time.
Well, I’ve done all that you told me. However, I couldn’t made it.

Today, I realized that I’m using windows 10 64bit.
Does this cause the error?

I mean, according to QGC install manual, Windows: Vista or higher, 32 bit, [Visual Studio 2015 compiler] is recommended.


(Patrick José Pereira) #10

Are you using a 32 or a 64 bits compiler ? It’s necessary to build with 32.