Home        Store        Docs        Blog

Video delay in QGC


(Oystein Skarholm) #1

I believe there have been several posts on this topic but they are scattered so I decided to start a new, fresh one.
Today 31.07.2017 after reinstalling the QGC (QGC from the link found in Blue Robotix site) I have a delay in the video feed that makes it almost impossible to perform close up inspection. The delay is about 2 seconds.
My laptop has a 1.2GHz CPU 4405U
RAM 4GB 64Bits
Win 10.

Any suggestion of what to do? Pixhawk was updated 2 -3 months back.

QGC version (not sure…it says development head b2c32643e 2017-06-21…in the top of the screen when running QGC)


Excessive Camera Latency
(Jacob) #2

Thank you @SDI for making a new topic on this.

Those with trouble in video delay can download a different QGC here. This QGC has video recording disabled in order to resolve the delay.

This issue appears to affect only a small percentage of Windows computers. We still have not identified the exact cause of the issue. I will make another update post when we are able to fix it.

-Jacob


(Jacob) #3

Just to clarify @SDI, the Pixhawk firmware (ArduSub) version/update has no connection to video performance.


(Roy Petter Dyrdahl Torgersen) #4

Hi @SDI just to confirm we have had similar issues and reverting to the other version of QGC that @jwalser mention solved the problem.

“You are not alone” :wink:


(Bo Koppel) #5

Hi!
Here is three different things that solved video problems in all our Win7 and Win10 laptops:

When using original power supply that supply laptop (but not charge at the same time) there is something probably in BIOS that slow down graphic card to save energy. That makes processor do some of the graphics calculations. (And actually consume even more energy!)
Solution: Go on battery or use a large powersupply (in our case 120W)
How to quick check if this is the problem: pull out powersupply, if this is the case, latency disappear in two seconds.

Nvidia powerful graphic cards use an engine called PhysX for games etc. It seams QGC does not use that.
Also QGC works default on motherboard graphic card, not on the more powerful Nvidia extension card.
Solution: In Nvidias “control panel” select under “Programs” QGC so Nvidia forces QGC to use Nvidia card.
Some graphic cards also needs tweeking in Nvidia 3D setup (same place as above line)

Real crazy in a few computers: Switch system fonts from 125% size to 100%
(Right click desktop, “adjust screen” then “monitor” translated from Swedish OS)
Check the 100% tickbox instead of 125%
Log out and log in again, fixed….


QGC no video stream (windows)
Software Updates - September 14 2017
(Jacob) #6

Incredible finds Bo, thank you for your diligence.


(Oystein Skarholm) #7

Is this version af QGC (July 31)still valid after the big update? The new QGC has video recording option and it comes with some video delay as well. I will check the windows 10settings issues as Bo described, but if it dont get bettter i was planning to uninstall the program and install the “old” version without video recordinh option. Will that effect all the new settings like turn couter / Lat Long display/ Gain display/dim display etc ?


(Jacob) #8

I have made another installer for the current version with video recording disabled.

You can get it here.